const regex = /^HAD(?:-OR(?:AAS|BTD)[0-9]{5,7}){1,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^HAD(?:-OR(?:AAS|BTD)[0-9]{5,7}){1,2}$', 'gm')
const str = `HAD-ORAAS0001545-ORBTD0003457
HAD-ORBTD0001545-ORAAS0003457`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}