use strict;
my $str = 'HAD-ORAAS0001545-ORBTD0003457
HAD-ORBTD0001545-ORAAS0003457';
my $regex = qr/^HAD(?:-OR(?:AAS|BTD)[0-9]{5,7}){1,2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}