$re = '/^HAD(?:-OR(?:AAS|BTD)[0-9]{5,7}){1,2}$/m';
$str = 'HAD-ORAAS0001545-ORBTD0003457
HAD-ORBTD0001545-ORAAS0003457';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);