package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^HAD(?:-OR(?:AAS|BTD)[0-9]{5,7}){1,2}$`)
var str = `HAD-ORAAS0001545-ORBTD0003457
HAD-ORBTD0001545-ORAAS0003457`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}