# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?(?=\d*[a-z]\d*[a-z]|$)//gmi;t' <<< "1234 123423-34 b4 3-z a 234 This is a test
1234 123423-34 b4 3-z a 234This is a test
1234 123423-34 b4 3-z a "