using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(?=\d*[a-z]\d*[a-z]|$)";
string substitution = @"";
string input = @"1234 123423-34 b4 3-z a 234 This is a test
1234 123423-34 b4 3-z a 234This is a test
1234 123423-34 b4 3-z a ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}