$re = '/^.*?(?=\d*[a-z]\d*[a-z]|$)/mi';
$str = '1234 123423-34 b4 3-z a 234 This is a test
1234 123423-34 b4 3-z a 234This is a test
1234 123423-34 b4 3-z a ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;