const regex = /^.*?(?=\d*[a-z]\d*[a-z]|$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(?=\\d*[a-z]\\d*[a-z]|$)', 'gmi')
const str = `1234 123423-34 b4 3-z a 234 This is a test
1234 123423-34 b4 3-z a 234This is a test
1234 123423-34 b4 3-z a `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);