import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(?=\\d*[a-z]\\d*[a-z]|$)";
final String string = "1234 123423-34 b4 3-z a 234 This is a test\n"
+ "1234 123423-34 b4 3-z a 234This is a test\n"
+ "1234 123423-34 b4 3-z a ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}