#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^.*?(?=\d*[a-z]\d*[a-z]|$)"
Local $sString = "1234 123423-34 b4 3-z a 234 This is a test" & @CRLF & _
"1234 123423-34 b4 3-z a 234This is a test" & @CRLF & _
"1234 123423-34 b4 3-z a "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)