import re
regex = re.compile(r"^.*?(?=\d*[a-z]\d*[a-z]|$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("1234 123423-34 b4 3-z a 234 This is a test\n"
"1234 123423-34 b4 3-z a 234This is a test\n"
"1234 123423-34 b4 3-z a ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)