# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/default = ssh:\\/\\/webfaction\\/\\/home\\/mwolfe02\\/webapps\\/hg\\/repos\\/(.*)$/default = ssh:\/\/opal\/\/home\/gb\/repos\/$1\nwebfaction = ssh:\/\/webfaction\/\/home\/mwolfe02\/webapps\/hg\/repos\/$1/gm;t' <<< "default = ssh://webfaction//home/mwolfe02/webapps/hg/repos/loan_mgmt"