use strict;
my $str = 'default = ssh://webfaction//home/mwolfe02/webapps/hg/repos/loan_mgmt';
my $regex = qr/default = ssh:\/\/webfaction\/\/home\/mwolfe02\/webapps\/hg\/repos\/(.*)$/mp;
my $subst = 'default = ssh://opal//home/gb/repos/$1\\nwebfaction = ssh://webfaction//home/mwolfe02/webapps/hg/repos/$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";