re = /default = ssh:\/\/webfaction\/\/home\/mwolfe02\/webapps\/hg\/repos\/(.*)$/m
str = 'default = ssh://webfaction//home/mwolfe02/webapps/hg/repos/loan_mgmt'
subst = 'default = ssh://opal//home/gb/repos/$1\\nwebfaction = ssh://webfaction//home/mwolfe02/webapps/hg/repos/$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result