const regex = /default = ssh:\/\/webfaction\/\/home\/mwolfe02\/webapps\/hg\/repos\/(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('default = ssh:\\\/\\\/webfaction\\\/\\\/home\\\/mwolfe02\\\/webapps\\\/hg\\\/repos\\\/(.*)$', 'gm')
const str = `default = ssh://webfaction//home/mwolfe02/webapps/hg/repos/loan_mgmt`;
const subst = `default = ssh://opal//home/gb/repos/$1\nwebfaction = ssh://webfaction//home/mwolfe02/webapps/hg/repos/$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);