import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "default = ssh:\\/\\/webfaction\\/\\/home\\/mwolfe02\\/webapps\\/hg\\/repos\\/(.*)$";
final String string = "default = ssh://webfaction//home/mwolfe02/webapps/hg/repos/loan_mgmt";
final String subst = "default = ssh://opal//home/gb/repos/$1\\nwebfaction = ssh://webfaction//home/mwolfe02/webapps/hg/repos/$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}