# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^:]+):\s*(.*)/$1: $2/gm;t' <<< "SNO :
19110
BLKNAME :
SETHUBAVACHATRAM
DISTRICTNA :
THANJAVUR
PANCHTYPE :
VP
RVILLNAME :
SEMBIYAMADEVIPATTINAM
TALUKNAME :
Peravurani"