const regex = /([^:]+):\s*(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^:]+):\\s*(.*)', 'gm')
const str = `SNO :
19110
BLKNAME :
SETHUBAVACHATRAM
DISTRICTNA :
THANJAVUR
PANCHTYPE :
VP
RVILLNAME :
SEMBIYAMADEVIPATTINAM
TALUKNAME :
Peravurani`;
const subst = `$1: $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);