$re = '/([^:]+):\s*(.*)/m';
$str = 'SNO :
19110
BLKNAME :
SETHUBAVACHATRAM
DISTRICTNA :
THANJAVUR
PANCHTYPE :
VP
RVILLNAME :
SEMBIYAMADEVIPATTINAM
TALUKNAME :
Peravurani';
$subst = "$1: $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;