using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^:]+):\s*(.*)";
string substitution = @"$1: $2";
string input = @"SNO :
19110
BLKNAME :
SETHUBAVACHATRAM
DISTRICTNA :
THANJAVUR
PANCHTYPE :
VP
RVILLNAME :
SEMBIYAMADEVIPATTINAM
TALUKNAME :
Peravurani";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}