re = /([^:]+):\s*(.*)/m
str = 'SNO :
19110
BLKNAME :
SETHUBAVACHATRAM
DISTRICTNA :
THANJAVUR
PANCHTYPE :
VP
RVILLNAME :
SEMBIYAMADEVIPATTINAM
TALUKNAME :
Peravurani'
subst = '$1: $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result