import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^:]+):\\s*(.*)";
final String string = "SNO :\n"
+ "19110\n"
+ "BLKNAME :\n"
+ "SETHUBAVACHATRAM\n"
+ "DISTRICTNA : \n"
+ "THANJAVUR\n"
+ "PANCHTYPE : \n"
+ "VP\n"
+ "RVILLNAME : \n"
+ "SEMBIYAMADEVIPATTINAM\n"
+ "TALUKNAME : \n"
+ "Peravurani";
final String subst = "$1: $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}