using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(,\s*)*|,\s*(?=,|$)";
string substitution = @"";
string input = @",,,, 'time_hour', 'loc', 'protocol_category', , 'mcc', 'imsi', 'service_dl_bytes', , ,,,,,,,,
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}