re = /^\s*(,\s*)*|,\s*(?=,|$)/
str = ',,,, \'time_hour\', \'loc\', \'protocol_category\', , \'mcc\', \'imsi\', \'service_dl_bytes\', , ,,,,,,,,
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result