import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(,\\s*)*|,\\s*(?=,|$)";
final String string = ",,,, 'time_hour', 'loc', 'protocol_category', , 'mcc', 'imsi', 'service_dl_bytes', , ,,,,,,,, \n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}