use strict;
my $str = ',,,, \'time_hour\', \'loc\', \'protocol_category\', , \'mcc\', \'imsi\', \'service_dl_bytes\', , ,,,,,,,,
';
my $regex = qr/^\s*(,\s*)*|,\s*(?=,|$)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";