const regex = /^\s*(,\s*)*|,\s*(?=,|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(,\\s*)*|,\\s*(?=,|$)', 'g')
const str = `,,,, 'time_hour', 'loc', 'protocol_category', , 'mcc', 'imsi', 'service_dl_bytes', , ,,,,,,,,
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);