import Foundation
let pattern = #"^\s*(,\s*)*|,\s*(?=,|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
,,,, 'time_hour', 'loc', 'protocol_category', , 'mcc', 'imsi', 'service_dl_bytes', , ,,,,,,,,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)