#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?isu)(\n)[\r\n]+|(<text>.*?</text>)"
Local $sString = "String 1" & @CRLF & _
"" & @CRLF & _
"String 2" & @CRLF & _
"" & @CRLF & _
"<tag1>" & @CRLF & _
"" & @CRLF & _
"Tag str 1" & @CRLF & _
"" & @CRLF & _
"Tag str 2" & @CRLF & _
"" & @CRLF & _
"</tag2>" & @CRLF & _
"" & @CRLF & _
"<text>" & @CRLF & _
"" & @CRLF & _
"Text" & @CRLF & _
"" & @CRLF & _
"Text 2" & @CRLF & _
"" & @CRLF & _
"Text 3" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"</text>" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)