import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\n)[\\r\\n]+|(<text>.*?</text>)";
final String string = "String 1\n\n"
+ "String 2\n\n"
+ "<tag1>\n\n"
+ "Tag str 1\n\n"
+ "Tag str 2\n\n"
+ "</tag2>\n\n"
+ "<text>\n\n"
+ "Text\n\n"
+ "Text 2\n\n"
+ "Text 3\n\n\n"
+ "</text>\n\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}