use strict;
my $str = 'String 1
String 2
<tag1>
Tag str 1
Tag str 2
</tag2>
<text>
Text
Text 2
Text 3
</text>
';
my $regex = qr~(\n)[\r\n]+|(<text>.*?</text>)~isup;
my $subst = '$1$2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";