package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(\n)[\r\n]+|(<text>.*?</text>)`)
var str = `String 1
String 2
<tag1>
Tag str 1
Tag str 2
</tag2>
<text>
Text
Text 2
Text 3
</text>
`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}