re = /(\n)[\r\n]+|(<text>.*?<\/text>)/i
str = 'String 1
String 2
<tag1>
Tag str 1
Tag str 2
</tag2>
<text>
Text
Text 2
Text 3
</text>
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result