import re
regex = re.compile(r"(\n)[\r\n]+|(<text>.*?</text>)", flags=re.IGNORECASE | re.DOTALL | re.UNICODE)
test_str = ("String 1\n\n"
"String 2\n\n"
"<tag1>\n\n"
"Tag str 1\n\n"
"Tag str 2\n\n"
"</tag2>\n\n"
"<text>\n\n"
"Text\n\n"
"Text 2\n\n"
"Text 3\n\n\n"
"</text>\n\n")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)