$re = '~(\n)[\r\n]+|(<text>.*?</text>)~isu';
$str = 'String 1
String 2
<tag1>
Tag str 1
Tag str 2
</tag2>
<text>
Text
Text 2
Text 3
</text>
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;