# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bjava\b(?!\.)/\/opt\/java17/gm;t' <<< "JAVA_VERSION=$(\"java\" -version 2>&1 | awk -F '\"' '/version/ {print $2}')
$java -DagentVersion=2.6.0 --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.lang.reflect=ALL-UNNAMED -jar"