import Foundation
let pattern = #"\bjava\b(?!\.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
JAVA_VERSION=$("java" -version 2>&1 | awk -F '"' '/version/ {print $2}')
$java -DagentVersion=2.6.0 --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.lang.reflect=ALL-UNNAMED -jar
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/opt/java17"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)