const regex = /\bjava\b(?!\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bjava\\b(?!\\.)', 'gm')
const str = `JAVA_VERSION=\$("java" -version 2>&1 | awk -F '"' '/version/ {print \$2}')
\$java -DagentVersion=2.6.0 --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.lang.reflect=ALL-UNNAMED -jar`;
const subst = `/opt/java17`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);