using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bjava\b(?!\.)";
string substitution = @"/opt/java17";
string input = @"JAVA_VERSION=$(""java"" -version 2>&1 | awk -F '""' '/version/ {print $2}')
$java -DagentVersion=2.6.0 --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.lang.reflect=ALL-UNNAMED -jar";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}