use strict;
my $str = 'JAVA_VERSION=$("java" -version 2>&1 | awk -F \'"\' \'/version/ {print $2}\')
$java -DagentVersion=2.6.0 --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.lang.reflect=ALL-UNNAMED -jar';
my $regex = qr/\bjava\b(?!\.)/mp;
my $subst = '/opt/java17';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";