import re
regex = re.compile(r"\bjava\b(?!\.)", flags=re.MULTILINE)
test_str = ("JAVA_VERSION=$(\"java\" -version 2>&1 | awk -F '\"' '/version/ {print $2}')\n\n"
"$java -DagentVersion=2.6.0 --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.lang.reflect=ALL-UNNAMED -jar")
subst = "/opt/java17"
result = regex.sub(subst, test_str)
if result:
print(result)