$re = '/\bjava\b(?!\.)/m';
$str = 'JAVA_VERSION=$("java" -version 2>&1 | awk -F \'"\' \'/version/ {print $2}\')
$java -DagentVersion=2.6.0 --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.lang.reflect=ALL-UNNAMED -jar';
$subst = "/opt/java17";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;