# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)(?=.*,(\w+)$)|\s+,\w+$/$1$2/gm;t' <<< "d ,c ,bb ,a
h ,g ,f ,ee
l ,kk ,j ,i
"