re = /(\w+)(?=.*,(\w+)$)|\s+,\w+$/m
str = 'd ,c ,bb ,a
h ,g ,f ,ee
l ,kk ,j ,i
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result