const regex = /(\w+)(?=.*,(\w+)$)|\s+,\w+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)(?=.*,(\\w+)$)|\\s+,\\w+$', 'gm')
const str = `d ,c ,bb ,a
h ,g ,f ,ee
l ,kk ,j ,i
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);