import Foundation
let pattern = #"(\w+)(?=.*,(\w+)$)|\s+,\w+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
d ,c ,bb ,a
h ,g ,f ,ee
l ,kk ,j ,i
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)