#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w+)(?=.*,(\w+)$)|\s+,\w+$"
Local $sString = "d ,c ,bb ,a" & @CRLF & _
"h ,g ,f ,ee" & @CRLF & _
"l ,kk ,j ,i" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)