$re = '/(\w+)(?=.*,(\w+)$)|\s+,\w+$/m';
$str = 'd ,c ,bb ,a
h ,g ,f ,ee
l ,kk ,j ,i
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;