using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)(?=.*,(\w+)$)|\s+,\w+$";
string substitution = @"$1$2";
string input = @"d ,c ,bb ,a
h ,g ,f ,ee
l ,kk ,j ,i
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}