# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<span.*?data-snippet-php="(.*?)".*?>.*?<\\/span>/$1/gm;t' <<< "HTML Code<br><span class=\"block\" title=\"Label: Titel\" data-snippet-php=\"<?php _e('Titel','grid_test') ?>\" editable=\"false\">[ Titel ]</span>: <span class=\"block\" title=\"Datenfeld: Titel\" data-snippet-bind=\"#: post_title #\" editable=\"false\">{ post_title }</span> text text text <span class=\"block\" title=\"Label: Desc\" data-snippet-php=\"<?php _e('Desc','grid_test') ?>\" editable=\"false\">[ Desc ]</span>: text text text"